summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-16 11:44:59 +0100
committerMarius Bakke <marius@gnu.org>2021-12-16 22:21:13 +0100
commit83651eef15bbdecd35b90c49de6d8476d70655a5 (patch)
tree8fdb0575d5cc630b500b5c7009ef96f4aaf5a30e /gnu/packages/python-xyz.scm
parentaec6bd0169bb855a3ec70f5edec0701d0a66ce9d (diff)
downloadguix-patches-83651eef15bbdecd35b90c49de6d8476d70655a5.tar
guix-patches-83651eef15bbdecd35b90c49de6d8476d70655a5.tar.gz
gnu: python-daemon: Fix test failure.
* gnu/packages/python-xyz.scm (python-daemon)[arguments]: Patch one test & remove trailing #t.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e26fe724f..8d34ea2e1e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4055,13 +4055,17 @@ logging and tracing of the execution.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-tests
+ (add-before 'check 'adjust-tests
(lambda _
+ ;; Drop use of testtools.helpers.safe_hasattr which has
+ ;; been removed in favor of hasattr.
+ (substitute* "test/test_metadata.py"
+ (("testtools\\.helpers\\.safe_hasattr")
+ "hasattr"))
;; FIXME: Determine why test fails
(substitute* "test/test_daemon.py"
(("test_detaches_process_context")
- "skip_test_detaches_process_context"))
- #t)))))
+ "skip_test_detaches_process_context")))))))
(propagated-inputs
(list python-lockfile))
(native-inputs