summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-15 19:30:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:49 +0200
commitf75aa97f9535170f581f780acec05a2c4298d4ba (patch)
tree47680841c97398d399621ae636e409b9f89db442 /gnu/packages/python-xyz.scm
parent82ff725df9f93fb5a864eec7803fdbb09f7f816b (diff)
downloadguix-patches-f75aa97f9535170f581f780acec05a2c4298d4ba.tar
guix-patches-f75aa97f9535170f581f780acec05a2c4298d4ba.tar.gz
gnu: Replace uses of texlive-*-amsfonts.
* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Replace texlive-fonts-amsfonts and texlive-latex-amsfonts with texlive-amsfonts in texlive-union. * gnu/packages/docbook.scm (dblatex)[inputs]: Same. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation, python-matplotlib-documentation, python-ipython-documentation) [native-inputs]: Same. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Same. * gnu/packages/tex.scm (teximpatient)[native-inputs]: Same.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 362ab7f031..ca3e3b642b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3495,12 +3495,11 @@ color scales, and color space conversion easy. It has support for:
("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)
("python-numpydoc" ,python-numpydoc)
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
- texlive-fonts-cm-super
+ ("texlive" ,(texlive-union (list texlive-fonts-cm-super
texlive-fonts-ec
texlive-generic-ifxetex
texlive-generic-pdftex
- texlive-latex-amsfonts
+ texlive-amsfonts
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ
@@ -3899,7 +3898,7 @@ toolkits.")
("python-ipykernel" ,python-ipykernel)
("python-mock" ,python-mock)
("graphviz" ,graphviz)
- ("texlive" ,(texlive-union (list texlive-latex-amsfonts
+ ("texlive" ,(texlive-union (list texlive-amsfonts
texlive-latex-amsmath
texlive-latex-enumitem
texlive-latex-expdlist
@@ -3910,7 +3909,6 @@ toolkits.")
texlive-generic-pdftex
- texlive-fonts-amsfonts
texlive-fonts-ec
texlive-fonts-adobe-times
texlive-fonts-txfonts)))
@@ -5467,11 +5465,10 @@ computing.")
`(("python-sphinx" ,python-sphinx)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
;; FIXME: It's possible that a smaller union would work just as well.
- ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ ("texlive" ,(texlive-union (list texlive-amsfonts
texlive-fonts-ec
texlive-generic-ifxetex
texlive-generic-pdftex
- texlive-latex-amsfonts
texlive-latex-capt-of
texlive-latex-cmap
texlive-latex-environ