summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-20 01:00:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-20 12:02:20 +0100
commitd8b79867696e0c79623925df500cf2973b35a793 (patch)
treef137fb16ee2599a7df84a436faa26f34e0417c8c /gnu/packages/python-xyz.scm
parentcf649c1e0d2cea329759d99c88e64f2b043ce8a5 (diff)
downloadguix-patches-d8b79867696e0c79623925df500cf2973b35a793.tar
guix-patches-d8b79867696e0c79623925df500cf2973b35a793.tar.gz
gnu: Add python-numpy-1.20.
* gnu/packages/python-xyz.scm (python-numpy-1.20): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 74f1879d69..6265770ff0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5345,6 +5345,25 @@ capabilities.")
(base32
"0lg1cycxzi4rvvrd5zxinpdz0ni792fpx6xjd75z1923zcac8qrb")))))))
+;; Needed by python-numba, see https://github.com/numba/numba/issues/7176
+(define-public python-numpy-1.20
+ (package
+ (inherit python-numpy)
+ (version "1.20.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/numpy/numpy/releases/download/v"
+ version "/numpy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "140zq9snx0di4id4g97vaw9zz8x2rfla5lp3a70j666f5030yd5p"))))
+ ;; 92 tests fail, many of them because parts of the temp file name
+ ;; accidentally ends up in a comparison.
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-numpy)
+ ((#:tests? _ #t) #f)))))
+
;; NOTE: NumPy 1.8 is packaged only for Python 2 because it is of
;; interest only for legacy code going back to NumPy's predecessor
;; Numeric.