summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-20 12:38:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-20 16:22:53 +0100
commit7ca5dc370da168a645a9f4aebb89c893936966b1 (patch)
treef673c539109a3a4ccbc4a434f4943f9737d8f207 /gnu/packages/python-xyz.scm
parentf407e4b0f9813dc52e15272cbb92bcdd35e8e45c (diff)
downloadguix-patches-7ca5dc370da168a645a9f4aebb89c893936966b1.tar
guix-patches-7ca5dc370da168a645a9f4aebb89c893936966b1.tar.gz
gnu: python-joblib: Update to 1.1.0.
* gnu/packages/python-xyz.scm (python-joblib): Update to 1.1.0. [arguments]: Disable one test.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a7b0c82de..4d0666cc36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4012,13 +4012,13 @@ logic-free templating system Mustache.")
(define-public python-joblib
(package
(name "python-joblib")
- (version "0.14.1")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "joblib" version))
(sha256
(base32
- "1j464w137w6s367gl697j1l63g52akydrxgv4czlck36ynjfwc06"))))
+ "0d8ypyhsw1bjr96zan9ms8wbvnzbjqxniq4vcszghcrps7ngqn21"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4027,7 +4027,9 @@ logic-free templating system Mustache.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "JOBLIB_MULTIPROCESSING" "0")
- (invoke "pytest" "-v" "joblib")))))))
+ (invoke "pytest" "-v" "joblib"
+ ;; We disable this test to avoid having to depend on ipython/jupyter
+ "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://joblib.readthedocs.io/")