summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-26 13:57:10 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-06-26 13:57:10 -0400
commit5c8369d6c12e5158d8131523ad644a9cba33869c (patch)
tree41cccd7aa70ce3cec0bbd1383ad359759ec7917b /gnu/packages/python-xyz.scm
parent2aa802ee5e871cbe99b3735ec9197454247b1c55 (diff)
downloadguix-patches-5c8369d6c12e5158d8131523ad644a9cba33869c.tar
guix-patches-5c8369d6c12e5158d8131523ad644a9cba33869c.tar.gz
gnu: Add python2-twodict.
* gnu/packages/python-xyz.scm (python2-twodict): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b92200beb..6c0930f8f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -239,6 +239,21 @@ remembers the order in which the items were inserted and supports almost all the
features of the Python's built-in dict.")
(license license:unlicense)))
+(define-public python2-twodict
+ (package
+ (inherit python-twodict)
+ (name "python2-twodict")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "twodict" version))
+ (sha256
+ (base32 "0ifv7dv18jn2lg0a3l6zdlvmmlda2ivixfjbsda58a2ay6kxznr0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))))
+
(define-public python-argopt
(package
(name "python-argopt")