summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-17 20:30:51 -0500
committerMathieu Othacehe <othacehe@gnu.org>2021-12-26 19:16:50 +0100
commit3fbe61fa50b7cab4cbbb8551f7ab9dc4735a0eb7 (patch)
tree6da4855f94f7227fbb1bc140b45c75c5da524c66 /gnu/packages/python-xyz.scm
parent2f0107d8a23cce8fb1074c85e4234e50f00ecf3a (diff)
downloadguix-patches-3fbe61fa50b7cab4cbbb8551f7ab9dc4735a0eb7.tar
guix-patches-3fbe61fa50b7cab4cbbb8551f7ab9dc4735a0eb7.tar.gz
gnu: Add python-logzero.
* gnu/packages/python-xyz.scm (python-logzero): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 73baa12666..bb4a3786a9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -273,6 +273,34 @@ asynchronous one follows
design}.")
(license license:asl2.0)))
+(define-public python-logzero
+ (package
+ (name "python-logzero")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "logzero" version))
+ (sha256
+ (base32 "10nh186vk6hpnpfycym44gja4fja0jyzw7q8dwimfd1rmv9xswvz"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest python-pytest-runner))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest")))))))
+ (home-page "https://github.com/metachris/logzero")
+ (synopsis "Robust and effective logging for Python")
+ (description
+ "@code{logzero} provides a fully configured Python logger object for
+easy logging and rotating to a console or a file.")
+ (license license:expat)))
+
(define-public python-logbook
(package
(name "python-logbook")