summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-29 15:11:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-07-05 10:14:02 +0300
commit032f4598f5fc5b5121bdced83b278c2369f14ef5 (patch)
tree9fd73689b00acf8e5c32dbbea4f012aa37be7657 /gnu/packages/python-xyz.scm
parent0ec7559875eacb85fec289377ff7b37723dd251e (diff)
downloadguix-patches-032f4598f5fc5b5121bdced83b278c2369f14ef5.tar
guix-patches-032f4598f5fc5b5121bdced83b278c2369f14ef5.tar.gz
gnu: python2-nbconvert: Remove package.
* gnu/packages/python-xyz.scm (python2-nbconvert): Remove variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 1 insertions, 32 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e655b3b20e..8435b0110b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11314,38 +11314,7 @@ convert an @code{.ipynb} notebook file into various static formats including:
@item ReStructured Text (rst)
@item executable script
@end enumerate\n")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-nbconvert))))))
-
-(define-public python2-nbconvert
- (let ((parent
- (package-with-python2
- (strip-python2-variant python-nbconvert))))
- (package
- (inherit parent)
- (version "5.0.0b1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "nbconvert" version))
- (sha256
- (base32
- "0brclbb18l4nmd5qy3dl9wn05rjdh1fz4rmzdlfqacj12rcdvdgp"))))
- (arguments
- `(;; The "bdist_egg" target is disabled by default, causing the installation
- ;; to fail.
- #:configure-flags (list "bdist_egg")
- ;; FIXME: 5 failures, 40 errors.
- #:tests? #f))
- (propagated-inputs
- `(("python-bleach" ,python-bleach)
- ("python-entrypoints" ,python-entrypoints)
- ("python-jinja2" ,python-jinja2)
- ("python-jupyter-core" ,python-jupyter-core)
- ("python-mistune" ,python-mistune)
- ("python-nbformat" ,python-nbformat)
- ("python-pygments" ,python-pygments)
- ("python-traitlets" ,python-traitlets))))))
+ (license license:bsd-3)))
(define-public python-notebook
(package