summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 03:20:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:58 -0400
commit4687f296e35f9e763dd56078d93990c7d545803e (patch)
tree731df10235e66e1f79f9f43e9a3fa562a8655bc2 /gnu/packages/python-xyz.scm
parentc7f95514c25bcdd8e6c9c7a105428ed007c1ac37 (diff)
downloadguix-patches-4687f296e35f9e763dd56078d93990c7d545803e.tar
guix-patches-4687f296e35f9e763dd56078d93990c7d545803e.tar.gz
gnu: Remove python2-backport-ssl-match-hostname.
* gnu/packages/python-xyz.scm (python2-backport-ssl-match-hostname): Delete variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a370e5e095..88c882eafa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1259,30 +1259,6 @@ access to various locale display names, localized number and date formatting,
etc.")
(license license:bsd-3)))
-(define-public python2-backport-ssl-match-hostname
- (package
- (name "python2-backport-ssl-match-hostname")
- (version "3.5.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "backports.ssl_match_hostname" version))
- (sha256
- (base32
- "1wndipik52cyqy0677zdgp90i435pmvwd89cz98lm7ri0y3xjajh"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; no test target
- (home-page "https://bitbucket.org/brandon/backports.ssl_match_hostname")
- (synopsis "Backport of ssl.match_hostname() function from Python 3.5")
- (description
- "This backport brings the ssl.match_hostname() function to users of
-earlier versions of Python. The function checks the hostname in the
-certificate returned by the server to which a connection has been established,
-and verifies that it matches the intended target hostname.")
- (license license:psfl)))
-
(define-public python-bidict
(package
(name "python-bidict")