summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 11:04:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:53 -0400
commitea754c74d3def755d79c5a50263b3aa185f4346c (patch)
tree5fd244299dea61d40f5f6dc9a4423c645a7c492a /gnu/packages/python-xyz.scm
parente5d34080229393b4f19fe312fbb667b9e3430afa (diff)
downloadguix-patches-ea754c74d3def755d79c5a50263b3aa185f4346c.tar
guix-patches-ea754c74d3def755d79c5a50263b3aa185f4346c.tar.gz
gnu: Add python-dictpath.
* gnu/packages/python-xyz.scm (python-dictpath): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2245e5605..4cd26d4038 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27135,6 +27135,25 @@ cryptographically signed ones).")
dictionaries.")
(license license:expat)))
+(define-public python-dictpath
+ (package
+ (name "python-dictpath")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dictpath" version))
+ (sha256
+ (base32 "1n4hq4wbgaw59bbb16nhkgg5wk8sl4iw940vjrgx4xmifqxxw73m"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-pytest-cov python-pytest-flake8))
+ (home-page "https://github.com/p1c2u/pathable")
+ (synopsis "Object-oriented path library for Python")
+ (description "This object-oriented dictionary path Python library enables
+traversing resources like paths or accessing resources on demand with separate
+accessor layer.")
+ (license license:asl2.0)))
+
(define-public pyzo
(package
(name "pyzo")