summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-05-15 20:20:08 -0400
committerLeo Famulari <leo@famulari.name>2022-05-15 20:22:02 -0400
commit40a729a0e6f1d660b942241416c1e2c567616d4d (patch)
treef9ba0c1bb87a1c8ef8ba6edb91f32bdf844207a8 /gnu/packages/python-xyz.scm
parentebb43029506d994bee0c2b890881fd61a0b0c202 (diff)
downloadguix-patches-40a729a0e6f1d660b942241416c1e2c567616d4d.tar
guix-patches-40a729a0e6f1d660b942241416c1e2c567616d4d.tar.gz
gnu: Fix the build of wicd.
Fixes <https://issues.guix.gnu.org/55440>. * gnu/packages/check.scm (python2-pytest-cov, python2-freezegun): Define without package-with-python2. * gnu/packages/python-xyz.scm (python2-babel): Likewise. * gnu/packages/time.scm (python2-dateutil): Likwise.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 020f078dee..199fcf5fb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1283,7 +1283,37 @@ etc.")
(license license:bsd-3)))
(define-public python2-babel
- (package-with-python2 python-babel))
+ (package
+ (name "python2-babel")
+ (version "2.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Babel" version))
+ (sha256
+ (base32
+ "018yg7g2pa6vjixx1nx41cfispgfi0azzp0a1chlycbj8jsil0ys"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python2-freezegun python2-pytest tzdata-for-tests))
+ (propagated-inputs
+ (list python2-pytz))
+ (arguments
+ `(#:python ,python-2
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (home-page "https://babel.pocoo.org/")
+ (synopsis
+ "Tools for internationalizing Python applications")
+ (description
+ "Babel is composed of two major parts:
+- tools to build and work with gettext message catalogs
+- a Python interface to the CLDR (Common Locale Data Repository), providing
+access to various locale display names, localized number and date formatting,
+etc.")
+ (license license:bsd-3)))
(define-public python2-backport-ssl-match-hostname
(package