summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-21 02:43:44 -0500
committerLeo Famulari <leo@famulari.name>2022-03-26 17:53:30 -0400
commitb9e01b7516f7cd4e83924bbb382b6e629382115e (patch)
treed12b0cebc7e242c650132491aeb678d98b02c015 /gnu/packages/python-xyz.scm
parentff4585d147ef3bb55c6cbbd86ca8fc582ad6b561 (diff)
downloadguix-patches-b9e01b7516f7cd4e83924bbb382b6e629382115e.tar
guix-patches-b9e01b7516f7cd4e83924bbb382b6e629382115e.tar.gz
gnu: Add python-msgpack-1.0.2.
* gnu/packages/python-xyz.scm (python-msgpack-1.0.2): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae335cc83f..c576d2106a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11321,6 +11321,17 @@ reading and writing MessagePack data.")
(home-page "https://pypi.org/project/msgpack/")
(license license:asl2.0)))
+(define-public python-msgpack-1.0.2
+ (package
+ (inherit python-msgpack)
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "msgpack" version))
+ (sha256
+ (base32
+ "1109s2yynrahwi64ikax68hx0mbclz8p35afmpphw5dwynb49q7s"))))))
+
;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
;; release 0.5. Some packages like borg still call it by the old name for now.
;; <https://bugs.gnu.org/30662>