summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <contact@phfrohring.com>2022-02-06 16:35:56 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-24 23:26:55 +0100
commit66cd0ce176fcebb21a0270083b1bb76ccd170d13 (patch)
treeea1afdd568d5e407f84865ca906c2a6b3d9a0e45 /gnu/packages/python-xyz.scm
parent462f3b064f0dd7f6f462b3a8deee5f438f4cd438 (diff)
downloadguix-patches-66cd0ce176fcebb21a0270083b1bb76ccd170d13.tar
guix-patches-66cd0ce176fcebb21a0270083b1bb76ccd170d13.tar.gz
gnu: Add python-psycopg2-binary.
* gnu/packages/python-xyz.scm (python-psycopg2-binary): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 739697b10f..cb50741f0e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29106,6 +29106,42 @@ multipurpose analysis in Python.")
static types.")
(license license:asl2.0)))
+(define-public python-psycopg2-binary
+ (package
+ (name "python-psycopg2-binary")
+ (version "2.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "psycopg2-binary" version))
+ (sha256
+ (base32
+ "0kpaxg3lg5wg5ww5kxmzi2z2d7arsx13ci915d8a2pf17lqza7bn"))))
+ (build-system python-build-system)
+ (inputs (list postgresql))
+ (arguments
+ ;; Tests are disable because they need a live instance of PostgreSQL.
+ '(#:tests? #f))
+ (home-page "https://psycopg.org/")
+ (synopsis "PostgreSQL database adapter for Python")
+ (description
+ "Psycopg is a PostgreSQL database adapter for the Python programming
+language. Its main features are the complete implementation of the Python DB
+API 2.0 specification and the thread safety (several threads can share the
+same connection). It was designed for heavily multi-threaded applications
+that create and destroy lots of cursors and make a large number of concurrent
+@code{INSERT}s or @code{UPDATE}s.
+
+Psycopg 2 is mostly implemented in C as a libpq wrapper, resulting in
+being both efficient and secure. It features client-side and
+server-side cursors, asynchronous communication and notifications,
+@code{COPY TO}/@code{COPY FROM} support. Many Python types are supported
+out-of-the-box and adapted to matching PostgreSQL data types;
+adaptation can be extended and customized thanks to a flexible objects
+adaptation system.
+
+Psycopg 2 is both Unicode and Python 3 friendly.")
+ (license license:lgpl3+)))
+
(define-public python-pyfuse3
(package
(name "python-pyfuse3")