summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-19 14:57:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-19 14:57:06 +0200
commit0fdec2a309bfc9c62b449524e3e71714674bca6e (patch)
treeddff6adbc273b58b0e57ce30dbc6594efa78d8b7 /gnu/packages/python-xyz.scm
parent04842543e8231d99aad4c8ec232f41272886fbd1 (diff)
downloadguix-patches-0fdec2a309bfc9c62b449524e3e71714674bca6e.tar
guix-patches-0fdec2a309bfc9c62b449524e3e71714674bca6e.tar.gz
gnu: tensorflow: Provide older setuptools version.
* gnu/packages/python-xyz.scm (python-setuptools-for-tensorflow): New public variable. * gnu/packages/machine-learning.scm (tensorflow)[native-inputs]: Add it.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65dffd33bf..6796f1c065 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -713,6 +713,19 @@ Python 3 support.")
(define-public python2-setuptools
(package-with-python2 python-setuptools))
+;; The setuptools provided by Python 3.7.4 is too new for Tensorflow.
+(define-public python-setuptools-for-tensorflow
+ (hidden-package
+ (package
+ (inherit python-setuptools)
+ (version "39.1.0")
+ (source (origin
+ (inherit (package-source python-setuptools))
+ (uri (pypi-uri "setuptools" version ".zip"))
+ (sha256
+ (base32
+ "1mzdhvfhnv4lggxa8rjl0dzqxvfx377gg5sqs57v89wrp09lwj65")))))))
+
(define-public python-uniseg
(package
(name "python-uniseg")