summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-26 00:35:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commit6cb645b73bbeffffa659deee8c01c8e763927412 (patch)
treef47eb2cd48438f638fa3d66877a40236b62f20e3 /gnu/packages/python-xyz.scm
parent0f22a96d9356e6307ef86ce9815a021374a34f6b (diff)
downloadguix-patches-6cb645b73bbeffffa659deee8c01c8e763927412.tar
guix-patches-6cb645b73bbeffffa659deee8c01c8e763927412.tar.gz
gnu: Add python-stripe.
* gnu/packages/python-xyz.scm (python-stripe): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c50e7355c4..88c89ed201 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26755,3 +26755,26 @@ banking site, so they work well if you want to pull together your finances
from multiple sources. Online trading accounts also often provide account
statements in OFX files.")
(license license:expat)))
+
+(define-public python-stripe
+ (package
+ (name "python-stripe")
+ (version "2.60.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stripe" version))
+ (sha256
+ (base32 "0258lzh4qikhinfggnlfh5aklcvg7lrvl8giqrh0yf0l61wvfrl9"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ;; tests require network
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page "https://github.com/stripe/stripe-python")
+ (synopsis "Python bindings for the Stripe financial services' API")
+ (description "This package provides access to the Stripe financial
+services' API. It includes a pre-defined set of classes for API resources
+that initialize themselves dynamically from API responses which makes it
+compatible with a wide range of versions of the Stripe API.")
+ (license license:expat)))