summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-24 17:05:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-24 23:54:21 -0400
commit6c2506d8df2c9254835637a1ac6a68ada11de781 (patch)
tree9f3c67edd0012c718794f28d0d303972c444ad87 /gnu/packages/python-xyz.scm
parent69f37702dfcda776a190d5c40fad8518469ce3c4 (diff)
downloadguix-patches-6c2506d8df2c9254835637a1ac6a68ada11de781.tar
guix-patches-6c2506d8df2c9254835637a1ac6a68ada11de781.tar.gz
gnu: Add python-wmctrl.
* gnu/packages/python-xyz.scm (python-wmctrl): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 257c1f9266..b659513800 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5530,6 +5530,34 @@ algorithm. Patiencediff provides a good balance of performance, nice output for
humans, and implementation simplicity.")
(license license:gpl2)))
+(define-public python-wmctrl
+ (package
+ (name "python-wmctrl")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wmctrl" version))
+ (sha256
+ (base32
+ "1q0l1sqnj5wma87k3dsgmsyph464syjc6fl8qcpa41nan1rgzjv6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((wmctrl (assoc-ref inputs "wmctrl")))
+ (substitute* "wmctrl.py"
+ (("'wmctrl")
+ (string-append "'" wmctrl "/bin/wmctrl")))))))))
+ (inputs `(("wmctrl" ,wmctrl)))
+ (home-page "https://github.com/antocuni/wmctrl")
+ (synopsis "Tool to programmatically control Xorg windows")
+ (description "This package provides a library for programmatically
+controlling Xorg windows using Python. The library relies on the
+@command{wmctrl} to do so.")
+ (license license:expat)))
+
(define-public python-pdftotext
(package
(name "python-pdftotext")