summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-25 23:12:39 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:23 +0200
commit4a258685586e59d0527bffe3c32d4b00b8536b50 (patch)
tree0a67ced146c3d75407b1d54fb6afb379764b8cf3 /gnu/packages/python-xyz.scm
parent1e3262d74fe96cf3bc3b8b3914379ef9e37672df (diff)
downloadguix-patches-4a258685586e59d0527bffe3c32d4b00b8536b50.tar
guix-patches-4a258685586e59d0527bffe3c32d4b00b8536b50.tar.gz
gnu: Add python-braintree.
* gnu/packages/python-xyz.scm (python-braintree): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4e2e719afc..bba468e205 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26561,3 +26561,23 @@ files and directories and adds a datestamp in standard ISO 8601+ format
YYYY-MM-DD at the beginning of the file or directory name.")
(home-page "https://github.com/novoid/date2name")
(license license:gpl3+))))
+
+(define-public python-braintree
+ (package
+ (name "python-braintree")
+ (version "4.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "braintree" version))
+ (sha256
+ (base32 "19kli85q18p80nsn8fm4ql6axpr7bllfqg5chv2ywhr8zr8bssll"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page
+ "https://developers.braintreepayments.com/python/sdk/server/overview")
+ (synopsis "Braintree Python Library")
+ (description "The Braintree Python SDK provides integration access to the
+Braintree Gateway. Braintree is a US-based payments service provider.")
+ (license license:expat)))