summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 11:16:41 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 12:42:47 +0100
commite92961a687c9626daadc6d2585f543f023d468b5 (patch)
tree658cae7465720bbcc1f31b25d78e2b71fba46be6 /gnu/packages/python-xyz.scm
parentdb501204f3ad5785df7d5fe51f6d47b75c5fa854 (diff)
downloadguix-patches-e92961a687c9626daadc6d2585f543f023d468b5.tar
guix-patches-e92961a687c9626daadc6d2585f543f023d468b5.tar.gz
gnu: Remove python-typing.
* gnu/packages/python-xyz.scm (python-typing): Merge with ... (python2-typing): ... this variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1caa54886f..c62e3b9546 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21387,9 +21387,9 @@ Python 3.6+ type hints.")
with PEP 484 argument (and return) type annotations.")
(license license:expat)))
-(define-public python-typing
+(define-public python2-typing
(package
- (name "python-typing")
+ (name "python2-typing")
(version "3.10.0.0")
(source
(origin
@@ -21398,6 +21398,7 @@ with PEP 484 argument (and return) type annotations.")
(sha256
(base32 "0c5il4d68fd4qrm5k3dps70j0xz0n5krj6lhwn9vzpal3whsvd0k"))))
(build-system python-build-system)
+ (arguments (list #:python python-2))
(home-page "https://docs.python.org/3/library/typing.html")
(synopsis "Type hints for Python")
(description "This is a backport of the standard library @code{typing}
@@ -21408,9 +21409,6 @@ to also be used by static and runtime type checkers, static analyzers, IDEs
and other tools.")
(license license:psfl)))
-(define-public python2-typing
- (package-with-python2 python-typing))
-
(define-public python-typing-extensions
(package
(name "python-typing-extensions")