summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-03-03 22:12:10 -0600
committerEric Bavier <bavier@member.fsf.org>2021-03-14 13:24:21 -0500
commit30f53814873349c9a1b48844a1cb36b6ea432513 (patch)
tree74cbda7bbf12ba31fff902273f2410b2a2f464da /gnu/packages/python-xyz.scm
parent207aa62e6ba476ecefd101ba7643b5afa9c1de20 (diff)
downloadguix-patches-30f53814873349c9a1b48844a1cb36b6ea432513.tar
guix-patches-30f53814873349c9a1b48844a1cb36b6ea432513.tar.gz
gnu: Add python-sortedcollections.
* gnu/packages/python-xyz.scm (python-sortedcollections): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dadf08f03d..7a633ee48b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2017, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
@@ -19877,6 +19877,26 @@ main differences are that @code{cytoolz} is faster and cytoolz offers a C API
that is accessible to other projects developed in Cython.")
(license license:bsd-3)))
+(define-public python-sortedcollections
+ (package
+ (name "python-sortedcollections")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sortedcollections" version))
+ (sha256
+ (base32
+ "1kfabpnjyjm5ml2zspry9jy3xq49aybchgaa4ahic2jqdjfn1sfq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sortedcontainers" ,python-sortedcontainers)))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball.
+ (home-page "http://www.grantjenks.com/docs/sortedcollections/")
+ (synopsis "Python Sorted Collections")
+ (description "Sorted Collections is a Python sorted collections library.")
+ (license license:asl2.0)))
+
(define-public python-sortedcontainers
(package
(name "python-sortedcontainers")