summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-14 11:48:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-14 11:48:10 +0200
commit753eb4118c974e4e9c685f81c8ffb45fc1be7274 (patch)
tree83a2ea3db50bd4d0376ca851f41d45ab59fd3cb3 /gnu/packages/python-xyz.scm
parent16c38e2b9cf2a004cb1d3425593b8872e5c1f7b4 (diff)
downloadguix-patches-753eb4118c974e4e9c685f81c8ffb45fc1be7274.tar
guix-patches-753eb4118c974e4e9c685f81c8ffb45fc1be7274.tar.gz
gnu: python-markupsafe: Update to 1.1.1.
* gnu/packages/python-xyz.scm (python-markupsafe): Update to 1.1.1. [arguments]: New field. Override check phase. [native-inputs]: Add PYTHON-PYTEST.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7c88e9187..ac23e23bc2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2298,15 +2298,33 @@ e.g. filters, callbacks and errbacks can all be promises.")
(define-public python-markupsafe
(package
(name "python-markupsafe")
- (version "1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "MarkupSafe" version))
(sha256
(base32
- "0rdn1s8x9ni7ss8rfiacj7x1085lx8mh2zdwqslnw8xc3l4nkgm6"))))
+ "0sqipg4fk7xbixqd8kq6rlkxj664d157bdwbh93farcphf92x1r9"))))
(build-system python-build-system)
+ (arguments
+ `(#:modules ((ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((cwd (getcwd))
+ (libdir (find (cut string-prefix? "lib." <>)
+ (scandir "build"))))
+ (setenv "PYTHONPATH"
+ (string-append cwd "/build/" libdir ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/mitsuhiko/markupsafe")
(synopsis "XML/HTML/XHTML markup safe string implementation for Python")
(description