summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-06 11:48:47 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-06 11:48:47 +0100
commit7e40d0ee90173607cd792af25a45a9c4a5740441 (patch)
treed8f8b168ae70b82dc9a17f010b8beabc5df6a257 /gnu/packages/python-xyz.scm
parentf72db02a6a139a40582232afd713dd513222eac5 (diff)
downloadguix-patches-7e40d0ee90173607cd792af25a45a9c4a5740441.tar
guix-patches-7e40d0ee90173607cd792af25a45a9c4a5740441.tar.gz
gnu: Add python-kivy-garden.
* gnu/packages/python-xyz.scm (python-kivy-garden): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a1e7f609df..895bcf3077 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16655,6 +16655,33 @@ as well.")
@end itemize")
(license license:bsd-3)))
+(define-public python-kivy-garden
+ (package
+ (name "python-kivy-garden")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kivy-garden" version))
+ (sha256
+ (base32 "0wkcpr2zc1q5jb0bi7v2dgc0vs5h1y7j42mviyh764j2i0kz8mn2"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'install 'remove-bat-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file
+ (string-append out "/bin/garden.bat"))))))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page "https://github.com/kivy-garden/garden")
+ (synopsis "Garden tool for Kivy flowers")
+ (description
+ "This package provides the @command{garden} command to install packages
+for Kivy, the multitouch application platform.")
+ (license license:expat)))
+
(define-public python-kivy
(package
(name "python-kivy")