summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:04:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commitd362b11d2a5f9b5a03914b3249568bdec19f7951 (patch)
treefa57d1d77a20aac47b5766eeb883dee8173e109f /gnu/packages/python-xyz.scm
parente253b94dc63d73ed7d26395048bf8f723d55b764 (diff)
downloadguix-patches-d362b11d2a5f9b5a03914b3249568bdec19f7951.tar
guix-patches-d362b11d2a5f9b5a03914b3249568bdec19f7951.tar.gz
gnu: Add python-cftime.
* gnu/packages/python-xyz.scm (python-cftime): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c01afdd191..7e3d96c84a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -113,6 +113,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages qt)
@@ -452,6 +453,33 @@ concepts.")
@code{subprocess} feature.")
(license license:expat)))
+(define-public python-cftime
+ (package
+ (name "python-cftime")
+ (version "1.0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cftime" version))
+ (sha256
+ (base32
+ "0362dhxbzk593walyjz30dll6y2y79wialik647cbwdsf3ad0x6x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-coveralls" ,python-coveralls)
+ ("python-cython" ,python-cython)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/Unidata/cftime")
+ (synopsis "Library for time handling")
+ (description
+ "This package provides time-handling functionality that used to be part
+of the netcdf4 package before.")
+ ;; This package claims to include code under the GPLv3 but is released
+ ;; under ISC.
+ (license (list license:isc license:gpl3+))))
+
(define-public python-netcdf4
(package
(name "python-netcdf4")