summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 16:59:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:29 +0100
commitd1c4f329d102ada27586a3430257d5c1e8d93b6b (patch)
tree83c8cca59843d49065425bc76734bf5e5165df06 /gnu/packages/python-xyz.scm
parent5d1ade85c424c7bac7aff36becf53f30fbe97e15 (diff)
downloadguix-patches-d1c4f329d102ada27586a3430257d5c1e8d93b6b.tar
guix-patches-d1c4f329d102ada27586a3430257d5c1e8d93b6b.tar.gz
gnu: python-orderedmultidict: Return #T from build phase.
* gnu/packages/python-xyz.scm (python-orderedmultidict)[arguments]: Unconditionally return #T from phase "fix-tests".
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cdeb63c9e4..ae12cfba0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3604,7 +3604,8 @@ where key might be occurred more than once in the container.")
;; The package uses nosetest for running the tests.
;; Adding this initfile allows to run the test suite
;; without requiring nosetest.
- (zero? (system* "touch" "tests/__init__.py")))))))
+ (with-output-to-file "tests/__init__.py" newline)
+ #t)))))
(propagated-inputs
`(("python-six" ,python-six)))
(native-inputs