summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:03:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:29 +0100
commit95b707fb467efccbf5939b0ed41d22c5be4414dd (patch)
treea224b694a8ea6f84137a09b136e9354d36d2ec55 /gnu/packages/python-xyz.scm
parentacb75c0328eccf30a3683a76d2bfed7ee5cfa9ed (diff)
downloadguix-patches-95b707fb467efccbf5939b0ed41d22c5be4414dd.tar
guix-patches-95b707fb467efccbf5939b0ed41d22c5be4414dd.tar.gz
gnu: python-honcho: Use INVOKE.
* gnu/packages/python-xyz.scm (python-honcho)[arguments]: Unconditionally return #T from "check" phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9c74e2b5f8..51fd320d66 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4148,7 +4148,7 @@ cluster without needing to write any wrapper code yourself.")
;; It's easier to run tests after install.
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
- (zero? (system* "py.test" "-v")))))))
+ (invoke "py.test" "-v"))))))
(home-page "https://github.com/nickstenning/honcho")
(synopsis "Manage Procfile-based applications")
(description