summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:14:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commit7904d6fa2c5b78958a5f9b39dad4d2446df26fd9 (patch)
treea4fc4258e4396e7e6cc86b5519c5363d6eaab282 /gnu/packages/python-xyz.scm
parent4f0a0894794c18f5f20cdbe43d853394be832328 (diff)
downloadguix-patches-7904d6fa2c5b78958a5f9b39dad4d2446df26fd9.tar
guix-patches-7904d6fa2c5b78958a5f9b39dad4d2446df26fd9.tar.gz
gnu: python-ptyprocess: Use INVOKE.
* gnu/packages/python-xyz.scm (python-ptyprocess)[arguments]: Unconditionally return #T from "check" phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 094fff4d20..2a3b5b56f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5756,8 +5756,7 @@ markdown_py is also provided to convert Markdown files to HTML.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (zero? (system* "nosetests")))))))
+ (lambda _ (invoke "nosetests"))))))
(home-page "https://github.com/pexpect/ptyprocess")
(synopsis "Run a subprocess in a pseudo terminal")
(description