summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 16:56:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:29 +0100
commit5d1ade85c424c7bac7aff36becf53f30fbe97e15 (patch)
treef7283cfa2b0b821a002f9ffbe70273453e42fca6 /gnu/packages/python-xyz.scm
parent1b66989bedc4999151fdc5184bb7fa5ed8ce0bc7 (diff)
downloadguix-patches-5d1ade85c424c7bac7aff36becf53f30fbe97e15.tar
guix-patches-5d1ade85c424c7bac7aff36becf53f30fbe97e15.tar.gz
gnu: python2-pysnptools: Update to 0.3.13.
* gnu/packages/python-xyz.scm (python2-pysnptools): Update to 0.3.13. [native-inputs]: Remove unzip; add python2-cython. [arguments]: Disable tests.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c5298ac82..cdeb63c9e4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3376,23 +3376,24 @@ toolkits.")
(define-public python2-pysnptools
(package
(name "python2-pysnptools")
- (version "0.3.9")
+ (version "0.3.13")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pysnptools" version ".zip"))
+ (uri (pypi-uri "pysnptools" version))
(sha256
(base32
- "1wybggjzz8zw7aav4pjsg2h22xp17a1lghrprza1pxwlm7wf96y2"))))
+ "0lnis5xsl7bi0hz4f7gbicahzi5zlxkc21nk3g374xv8fb5hb3qm"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2)) ; only Python 2.7 is supported
+ `(#:python ,python-2 ; only Python 2.7 is supported
+ #:tests? #f)) ; test files (e.g. examples/toydata.bim) not included
(propagated-inputs
`(("python2-numpy" ,python2-numpy)
("python2-scipy" ,python2-scipy)
("python2-pandas" ,python2-pandas)))
(native-inputs
- `(("unzip" ,unzip)))
+ `(("python2-cython" ,python2-cython)))
(home-page "http://microsoftgenomics.github.io/PySnpTools/")
(synopsis "Library for reading and manipulating genetic data")
(description