summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:22:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commit21ccc01d4c7fdddf8b956d6433ad980a78132b89 (patch)
tree86d40915d63d5fb14c16f5f9077ce792dd89cd7b /gnu/packages/python-xyz.scm
parent49ff882740871866e0db74ae1223ca87e0ec9f17 (diff)
downloadguix-patches-21ccc01d4c7fdddf8b956d6433ad980a78132b89.tar
guix-patches-21ccc01d4c7fdddf8b956d6433ad980a78132b89.tar.gz
gnu: python-odfpy: Use INVOKE.
* gnu/packages/python-xyz.scm (python-odfpy)[arguments]: Unconditionally return #T from "check" phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 789eb8ab7d..42b5a097ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9990,9 +9990,9 @@ discovery, monitoring and configuration.")
;; The test runner invokes python2 and python3 for test*.py.
;; To avoid having both in inputs, we replicate it here.
(lambda _
- (every (lambda (test-file)
- (zero? (system* "python" test-file)))
- (find-files "tests" "^test.*\\.py$")))))))
+ (for-each (lambda (test-file) (invoke "python" test-file))
+ (find-files "tests" "^test.*\\.py$"))
+ #t)))))
(build-system python-build-system)
(home-page "https://github.com/eea/odfpy")
(synopsis "Python API and tools to manipulate OpenDocument files")