summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 20:36:25 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:00 +0100
commit8830d9f900f3dc2107a0ce9541312579fa6ccb6e (patch)
tree1e381f3626d5012b6fe8631b3fe5a29739f187e5 /gnu/packages/python-xyz.scm
parentb62737097ca6c68bead5ae4e27d5098bb03e09cd (diff)
downloadguix-patches-8830d9f900f3dc2107a0ce9541312579fa6ccb6e.tar
guix-patches-8830d9f900f3dc2107a0ce9541312579fa6ccb6e.tar.gz
gnu: python-pytest-asyncio: Update to 0.17.2.
* gnu/packages/check.scm (python-pytest-asyncio): Update to 0.17.2. [arguments]: Specify setuptools-scm version. Replace check phase. [native-inputs]: Remove PYTHON-COVERAGE. Add PYTHON-FLAKY and PYTHON-SETUPTOOLS-SCM. * gnu/packages/python-xyz.scm (python-tqdm, python-watchgod)[arguments]: Specify asyncio_mode when running tests.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d3a8c7a5f..450b5fc498 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20227,7 +20227,9 @@ ignoring formatting changes.")
'(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "pytest" "-vv" "-k" "not perf"))))))
+ (invoke "pytest" "-vv"
+ "-o" "asyncio_mode=auto"
+ "-k" "not perf"))))))
(native-inputs
(list python-pytest python-pytest-asyncio python-pytest-timeout
python-setuptools-scm python-toml))
@@ -24884,7 +24886,8 @@ but portable.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv")))))))
+ (invoke "pytest" "-vv"
+ "-o" "asyncio_mode=auto")))))))
(native-inputs
(list python-coverage
python-pygments