summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 01:30:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 02:13:54 +0200
commit2bf9cc5ea714185cc380bbe3bb6b3391bc26c9b1 (patch)
tree1af5e274640634892583ab1071f0d06d6e3ab192 /gnu/packages/python-xyz.scm
parent46eb357973f711b59bb1312025c9248010dc1040 (diff)
downloadguix-patches-2bf9cc5ea714185cc380bbe3bb6b3391bc26c9b1.tar
guix-patches-2bf9cc5ea714185cc380bbe3bb6b3391bc26c9b1.tar.gz
gnu: python-prompt-toolkit: Specify the correct Python 2 variant.
* gnu/packages/python-xyz.scm (python-prompt-toolkit)[properties]: The Python-2 version of this package is version 2.x of this package.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 52c83a0402..1d99c19974 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13101,7 +13101,8 @@ interfaces in Python. It's like GNU Readline but it also features syntax
highlighting while typing, out-of-the-box multi-line input editing, advanced
code completion, incremental search, support for Chinese double-width
characters, mouse support, and auto suggestions.")
- (license license:bsd-3)))
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python-prompt-toolkit-2))))))
(define-public python-prompt-toolkit-2
(package (inherit python-prompt-toolkit)
@@ -13117,7 +13118,8 @@ characters, mouse support, and auto suggestions.")
(propagated-inputs
`(("python-wcwidth" ,python-wcwidth)
("python-six" ,python-six)
- ("python-pygments" ,python-pygments)))))
+ ("python-pygments" ,python-pygments)))
+ (properties '())))
(define-public python2-prompt-toolkit
(package-with-python2 python-prompt-toolkit-2))