summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:06 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-26 23:59:29 +0100
commit46bc8c0d5972fe54dce45db46eba030bf104fa9c (patch)
tree83a760fede74061729321c1abeaa41b3dbc96795 /gnu/packages/python-xyz.scm
parentf53fc9afbeb06444cf0d2bf92c4cab893b6b5889 (diff)
downloadguix-patches-46bc8c0d5972fe54dce45db46eba030bf104fa9c.tar
guix-patches-46bc8c0d5972fe54dce45db46eba030bf104fa9c.tar.gz
gnu: Add python-click-repl.
* gnu/packages/python-xyz.scm (python-click-repl): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb4a3786a9..f425292d75 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4243,6 +4243,37 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
format.")
(license license:unlicense)))
+(define-public python-click-repl
+ (package
+ (name "python-click-repl")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/click-contrib/click-repl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16ybsnwlj2jlqcfxflky8jz7i3nhrd3f6mvkpgs95618l8lx994i"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-click python-prompt-toolkit python-six))
+ (home-page "https://github.com/untitaker/click-repl")
+ (synopsis "REPL plugin for Click")
+ (description "This package provides a REPL plugin for Click.")
+ (license license:expat)))
+
(define-public python-doc8
(package
(name "python-doc8")