summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius.bakke@usit.uio.no>2021-02-06 10:42:03 +0100
committerMarius Bakke <marius@gnu.org>2021-02-06 13:13:57 +0100
commit82f09bd0e052a015999220657c46bb1febba674c (patch)
tree79b029f40654891a59d7d8267d8ccfe0965c5a08 /gnu/packages/python-xyz.scm
parent8bde37b03f3a5b6b76ea2b525b97d445b505d684 (diff)
downloadguix-patches-82f09bd0e052a015999220657c46bb1febba674c.tar
guix-patches-82f09bd0e052a015999220657c46bb1febba674c.tar.gz
gnu: Add python-multiprocessing-logging.
* gnu/packages/python-xyz.scm (python-multiprocessing-logging): New public variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 209bf5a6bc..e879742e5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016, 2017, 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -11975,6 +11975,28 @@ programmatically interfacing with your system's $EDITOR.")
(define-public python2-editor
(package-with-python2 python-editor))
+(define-public python-multiprocessing-logging
+ (package
+ (name "python-multiprocessing-logging")
+ (version "0.3.1")
+ (home-page "https://github.com/jruere/multiprocessing-logging")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1625wy3djlr3b2fpd3vi822f8gw6b75mnls5a4318dbi9za5pf0y"))))
+ (build-system python-build-system)
+ (synopsis "Manage logs from multiple processes")
+ (description
+ "This Python module implements a multiprocessing-aware @code{Handler}
+that, when set on the root @code{Logger}, will tunnel log records to the
+main process so that they are handled correctly.")
+ (license license:lgpl3+)))
+
(define-public python-vobject
(package
(name "python-vobject")