summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-25 23:28:57 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:23 +0200
commitde5b9aefbe7fd20562fb028457dbcf9a4278c79a (patch)
tree7e5031f11797bdfd5342445c3afc6f5ea908c50e /gnu/packages/python-xyz.scm
parent4a258685586e59d0527bffe3c32d4b00b8536b50 (diff)
downloadguix-patches-de5b9aefbe7fd20562fb028457dbcf9a4278c79a.tar
guix-patches-de5b9aefbe7fd20562fb028457dbcf9a4278c79a.tar.gz
gnu: Add python-markuppy.
* gnu/packages/python-xyz.scm (python-markuppy): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bba468e205..a3d1b74558 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26581,3 +26581,21 @@ YYYY-MM-DD at the beginning of the file or directory name.")
(description "The Braintree Python SDK provides integration access to the
Braintree Gateway. Braintree is a US-based payments service provider.")
(license license:expat)))
+
+(define-public python-markuppy
+ (package
+ (name "python-markuppy")
+ (version "1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "MarkupPy" version))
+ (sha256
+ (base32 "0pqdmpxbr8iq22b4css2gz5z6s01ddpzyj25x27kgbs2lp0f5phs"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/tylerbakke/MarkupPy")
+ (synopsis "A pythonic HTML/XML generator")
+ (description "This Python module attempts to make it easier to generate
+HTML/XML from a Python program in an intuitive, lightweight, customizable and
+pythonic way.")
+ (license license:expat)))