summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-02-17 15:38:29 +0100
committerAndreas Enge <andreas@enge.fr>2019-02-17 15:38:29 +0100
commit966aa714c8d43ba00192ac0273f286b82a290b9a (patch)
treee7d4ae7614ffcbbc818fba18a0ff798ada5a5702 /gnu/packages/python-xyz.scm
parenta778f27003dc1450a57f76454b791de239110bf1 (diff)
downloadguix-patches-966aa714c8d43ba00192ac0273f286b82a290b9a.tar
guix-patches-966aa714c8d43ba00192ac0273f286b82a290b9a.tar.gz
gnu: Add python-pari-jupyter.
* gnu/packages/python-xyz.scm (python-pari-jupyter): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3741e4b98d..811cbaf03e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4682,6 +4682,31 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python2-ipykernel
(package-with-python2 python-ipykernel))
+(define-public python-pari-jupyter
+ (package
+ (name "python-pari-jupyter")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pari_jupyter" version))
+ (sha256
+ (base32
+ "1yash0p422nnin7z58b99d0p23nx79f5m0mainc9hsjg72jhdhr6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-ipykernel" ,python-ipykernel)))
+ (inputs
+ `(("pari-gp" ,pari-gp)
+ ("readline" ,readline)))
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (home-page
+ "https://github.com/jdemeyer/pari_jupyter")
+ (synopsis "A Jupyter kernel for PARI/GP")
+ (description "The package provides a PARI/GP kernel for Jupyter.")
+ (license license:gpl3+)))
+
;; This is the latest release of the LTS version of ipython with support for
;; Python 2.7 and Python 3.x. Later non-LTS versions starting from 6.0 have
;; dropped support for Python 2.7. We may want to rename this package.