summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-09-08 23:53:00 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-19 12:25:42 -0700
commitaf760990e9651be865ccd20b935863d85f605f2e (patch)
tree8a17dc722b352b9cf68bb254f09f9fb5d0afd421 /gnu/packages/python-xyz.scm
parent4d83157cd806aeb864664ebb380c19f6be04648c (diff)
downloadguix-patches-af760990e9651be865ccd20b935863d85f605f2e.tar
guix-patches-af760990e9651be865ccd20b935863d85f605f2e.tar.gz
gnu: Add python-editorconfig.
* gnu/packages/python-xyz (python-editorconfig): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 601e4b13df..44aa471bb1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -882,6 +882,27 @@ messages in color.")
(define-public python2-coloredlogs
(package-with-python2 python-coloredlogs))
+(define-public python-editorconfig
+ (package
+ (name "python-editorconfig")
+ (version "0.12.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "EditorConfig" version))
+ (sha256
+ (base32
+ "0v55z351p9qkyp3bbspwywwn28sbcknhirngjbj779n3z52z63hv"))))
+ (build-system python-build-system)
+ (home-page "https://editorconfig.org/")
+ (synopsis "EditorConfig bindings for python")
+ (description "The EditorConfig project consists of a file format for
+defining coding styles and a collection of text editor plugins that enable
+editors to read the file format and adhere to defined styles. EditorConfig
+files are easily readable and they work nicely with version control systems.")
+ ;; "fnmatch.py" and "ini.py" are licensed under psfl, the rest is bsd-2.
+ (license (list license:bsd-2 license:psfl))))
+
(define-public python-et-xmlfile
(package
(name "python-et-xmlfile")