summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-19 00:11:37 +0100
committerMarius Bakke <marius@gnu.org>2022-01-19 10:05:30 +0100
commit7b11fd565cc1799b0ba07c121ce4e40eb772b1c9 (patch)
tree268875fb897ae1e64f94247c9099952eebc686f6 /gnu/packages/python-xyz.scm
parentd98af3f7c18ab6f1931154e4fe5af9fcaa5e4e50 (diff)
downloadguix-patches-7b11fd565cc1799b0ba07c121ce4e40eb772b1c9.tar
guix-patches-7b11fd565cc1799b0ba07c121ce4e40eb772b1c9.tar.gz
gnu: Add python-retry.
* gnu/packages/python-xyz.scm (python-retry): New public variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83dd6dafc3..223c4533a6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27050,6 +27050,31 @@ integration, human-readable errors, and standard OS-specific locations.")
implementations.")
(license license:expat)))
+(define-public python-retry
+ (package
+ (name "python-retry")
+ (version "0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "retry" version))
+ (sha256
+ (base32 "197v6qrh6858bhzzrjgk2zdqrybppymb1lsvdxnm1i39kfwsigzq"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pbr python-pytest))
+ (propagated-inputs (list python-decorator python-py))
+ (home-page "https://github.com/invl/retry")
+ (synopsis "Retry decorator")
+ (description
+ "@code{retry} is an easy to use retry decorator for Python. It can be
+used to retry a function a given number of times.")
+ (license license:asl2.0)))
+
(define-public python-pivy
(package
(name "python-pivy")