summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-01 16:42:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-02 15:25:12 +0100
commitca7c365312d3af6f664868690f02c385f07e34a1 (patch)
tree4fe59c817dfd4c3fe4a5db39aa48cd80aea6adb6 /gnu/packages/python-xyz.scm
parent5fbdd917b73d30ef5ca0aa4e82b8d0a5f81394dd (diff)
downloadguix-patches-ca7c365312d3af6f664868690f02c385f07e34a1.tar
guix-patches-ca7c365312d3af6f664868690f02c385f07e34a1.tar.gz
gnu: python-scikit-image: Move to (gnu packages python-science).
* gnu/packages/python-xyz.scm (python-scikit-image, python2-scikit-image): Move these two from here... * gnu/packages/python-science.scm: ...to this new file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 1 insertions, 36 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6d86eb1b22..1d6f0a8367 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -128,6 +128,7 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -3307,42 +3308,6 @@ Mallard using the @command{ducktype} tool. The yelp-tools package
provides additional functionality on the produced Mallard documents.")
(license license:expat)))
-(define-public python-scikit-image
- (package
- (name "python-scikit-image")
- (version "0.14.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "scikit-image" version))
- (sha256
- (base32 "07qchljkyxvg5nrm12fvszi7pmjk4m01qp0w0z8syxzxxs20pz8s"))))
- (build-system python-build-system)
- (arguments
- ;; TODO: Some tests require running X11 server. Disable them?
- '(#:tests? #f))
- ;; See DEPENDS.txt for the list of build and run time requiremnts
- (propagated-inputs
- `(("python-cloudpickle" ,python-cloudpickle)
- ("python-dask" ,python-dask)
- ("python-matplotlib" ,python-matplotlib)
- ("python-networkx" ,python-networkx)
- ("python-numpy" ,python-numpy)
- ("python-pillow" ,python-pillow)
- ("python-pywavelets" ,python-pywavelets)
- ("python-scipy" ,python-scipy)
- ("python-six" ,python-six)))
- (native-inputs
- `(("python-cython" ,python-cython)))
- (home-page "http://scikit-image.org/")
- (synopsis "Image processing in Python")
- (description
- "Scikit-image is a collection of algorithms for image processing.")
- (license license:bsd-3)))
-
-(define-public python2-scikit-image
- (package-with-python2 python-scikit-image))
-
(define-public python-cython
(package
(name "python-cython")