summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 20:58:45 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 20:58:45 +0200
commit0b31e45b49af76d02ad760162ffe69d6c3cb854f (patch)
tree07c3d8a08b460809abfd8949637a5079b7fa3f55 /gnu/packages/python-xyz.scm
parent11ac8ac6fabf3c244881bb770f47c437984591cb (diff)
downloadguix-patches-0b31e45b49af76d02ad760162ffe69d6c3cb854f.tar
guix-patches-0b31e45b49af76d02ad760162ffe69d6c3cb854f.tar.gz
gnu: Add python-logutils.
* gnu/packages/python-xyz.scm (python-logutils): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b10b55357f..973da15cad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25194,6 +25194,27 @@ query Watchman to discover file changes.")
environment.")
(license license:expat)))
+(define-public python-logutils
+ (package
+ (name "python-logutils")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "logutils" version))
+ (sha256
+ (base32
+ "10lsi5wv5ysnvf9ya4ncbix6mmipnv5067sf2cglc2f2sljql1dw"))))
+ (build-system python-build-system)
+ (home-page "https://bitbucket.org/vinay.sajip/logutils/")
+ (synopsis "Logging utilities")
+ (description "This package provides a set of handlers for the Python
+standard library logging package. Some of these handlers are out-of-scope
+for the standard library, and so they are packaged here. Others are updated
+versions which have appeared in recent Python releases, but are usable with
+older versions of Python and so are packaged here.")
+ (license license:bsd-3)))
+
(define-public python-qtsass
(package
(name "python-qtsass")