summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:37 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:32 +0100
commitabb259b1bf0ab27c41f093d821a94ca6337ec4f5 (patch)
tree2ea740d99eff64e3be977f0d9349fbfc964680c6 /gnu/packages/python-xyz.scm
parentdf1e2353df51fe1e8ff99724840b6fe3611a4cea (diff)
downloadguix-patches-abb259b1bf0ab27c41f093d821a94ca6337ec4f5.tar
guix-patches-abb259b1bf0ab27c41f093d821a94ca6337ec4f5.tar.gz
gnu: python-colorlog: Update to 6.6.0.
* gnu/packages/python-xyz.scm (python-colorlog): Update to 6.6.0. [source]: Make some cosmetic changes. [arguments]<#:phases>: Simplify custom 'check phase and respect #:tests?. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 11c3f0d6ea..845523c5bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -769,21 +769,24 @@ implementation for the Telegram Bot API.")
(define-public python-colorlog
(package
(name "python-colorlog")
- (version "4.1.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "colorlog" version))
- (sha256
- (base32
- "1lpk8zmfv8vz090h5d0hzb4n39wgasxdd3x3bpn3v1x1n9dfzaih"))))
+ (version "6.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colorlog" version))
+ (sha256
+ (base32 "1s7x0v872h8aks8xp01wmv6hzisxqjrh1svbbcycir0980h76krl"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
(native-inputs
(list python-pytest))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-p" "no:logging"))))))
(home-page "https://github.com/borntyping/python-colorlog")
(synopsis "Log formatting with colors for python")
(description "The @code{colorlog.ColoredFormatter} is a formatter for use