summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-26 00:22:50 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commit0f22a96d9356e6307ef86ce9815a021374a34f6b (patch)
tree86c199cac505e40d21c1fd16f201ffb4e1cc608a /gnu/packages/python-xyz.scm
parentafc45931ea3eabe884223d13cb1bd73f00ce2e0e (diff)
downloadguix-patches-0f22a96d9356e6307ef86ce9815a021374a34f6b.tar
guix-patches-0f22a96d9356e6307ef86ce9815a021374a34f6b.tar.gz
gnu: Add python-ofxparse.
* gnu/packages/python-xyz.scm (python-ofxparse): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79f651bdc7..c50e7355c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26721,3 +26721,37 @@ spreadsheet), CSV, TSV, XLS, XLSX (Microsoft Excel spreadsheet), and YAML.")
(description "This package provides a module to parse Coded statement of
account (CODA) files as defined be the Belgian Febelfin bank standard.")
(license license:bsd-3)))
+
+(define-public python-ofxparse
+ (package
+ (name "python-ofxparse")
+ (version "0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ofxparse" version))
+ (sha256
+ (base32 "19y4sp5l9jqiqzzlbqdfiab42qx7d84n4xm4s7jfq397666vcyh5"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "nosetests" "-v")))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-lxml" ,python-lxml)
+ ("python-six" ,python-six)))
+ (home-page "http://sites.google.com/site/ofxparse")
+ (synopsis "Tools for working with the OFX (Open Financial Exchange) file
+format")
+ (description "@code{ofxparse} is a parser for Open Financial
+Exchange (.ofx) format files. OFX files are available from almost any online
+banking site, so they work well if you want to pull together your finances
+from multiple sources. Online trading accounts also often provide account
+statements in OFX files.")
+ (license license:expat)))