summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-10-25 10:38:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-25 14:32:59 +0200
commitb87fe805aa66851f17f56078cb0e94f7cc4525df (patch)
tree362a26efeffafa44c5683073614bb59aa4fcf884 /gnu/packages/python-xyz.scm
parentbb524f43fb1722f4a3e948b7fae5b795077e86d1 (diff)
downloadguix-patches-b87fe805aa66851f17f56078cb0e94f7cc4525df.tar
guix-patches-b87fe805aa66851f17f56078cb0e94f7cc4525df.tar.gz
gnu: python-peachpy: Make output deterministic.
Fixes <https://issues.guix.gnu.org/50672>. This makes users of python-peachpy bit-reproducible, such as nnpack. * gnu/packages/patches/python-peachpy-determinism.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-xyz.scm (python-peachpy)[source]: Use it. Co-authored-by: Kyle Meyer <kyle@kyleam.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb9fcc310d..a7b1e0efe2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27118,7 +27118,8 @@ and BMI2).")
(file-name (git-file-name name version))
(sha256
(base32
- "1yy62k3cjr6556nbp651w6v4hzl7kz4y75wy2dfqgndgbnixskx2"))))
+ "1yy62k3cjr6556nbp651w6v4hzl7kz4y75wy2dfqgndgbnixskx2"))
+ (patches (search-patches "python-peachpy-determinism.patch"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases