summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-28 05:01:56 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-11 00:21:37 +0100
commit5592058e9d72e1960bfde52dc9744f51518ebb74 (patch)
tree49abdaebdb6f468bd10b599285ba36265b208db5 /gnu/packages/python-xyz.scm
parent800afd26f43803417db5373c905dfbc7ed4d6f92 (diff)
downloadguix-patches-5592058e9d72e1960bfde52dc9744f51518ebb74.tar
guix-patches-5592058e9d72e1960bfde52dc9744f51518ebb74.tar.gz
gnu: Add python-wand.
* gnu/packages/python-xyz.scm (python-wand): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f33046985a..a01a14f29b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1553,6 +1553,35 @@ and simplified. It supports SPDX license expressions as well as other naming
conventions and aliases in the same expression.")
(license license:gpl2+)))
+(define-public python-wand
+ (package
+ (name "python-wand")
+ (version "0.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Wand" version))
+ (sha256
+ (base32 "1nxn7zvbnfgk4kkxajbzglcjpbgr84ilhnxm990nifjxqb61ph7b"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'find-magickwand
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
+ (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (inputs
+ `(("imagemagick" ,imagemagick)))
+ (home-page "https://docs.wand-py.org/")
+ (synopsis "MagickWand API binding for Python")
+ (description
+ "Wand is a ctypes-based binding for the C API of ImageMagick's MagickWand
+library.")
+ (license license:expat)))
+
(define-public python-lockfile
(package
(name "python-lockfile")