summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-10 01:05:40 -0500
committerArun Isaac <arunisaac@systemreboot.net>2021-11-15 11:57:18 +0530
commit1fc71de3abbd7e205d2037cd0263c6a1026d3643 (patch)
tree2af5b51ce2fcd00ecffcb4bf57177612e436b06a /gnu/packages/python-xyz.scm
parent272e8f50511a551ce1c0a941c949c8ffafd849ff (diff)
downloadguix-patches-1fc71de3abbd7e205d2037cd0263c6a1026d3643.tar
guix-patches-1fc71de3abbd7e205d2037cd0263c6a1026d3643.tar.gz
gnu: python-orderedmultidict: Update to 1.0.1.
* gnu/packages/python-xyz.scm (python-orderedmultidict): Update to 1.0.1. [arguments]: Delete custom fix-tests phase. [native-inputs]: Add python-flake8. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3d34ea4ba7..afc86ec559 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6682,29 +6682,20 @@ where key might be occurred more than once in the container.")
(define-public python-orderedmultidict
(package
(name "python-orderedmultidict")
- (version "1.0")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "orderedmultidict" version))
(sha256
(base32
- "1idjbl933avgaadscrjw1np3xkvnz3phq0l8vw5qs0rqcjx9b65q"))))
+ "1bc2v0yflsxjyyjx4q9wqx0j3bvzcw9z87d5pz4iqac7bsxhn1q4"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- ;; The package uses nosetest for running the tests.
- ;; Adding this initfile allows to run the test suite
- ;; without requiring nosetest.
- (with-output-to-file "tests/__init__.py" newline)
- #t)))))
(propagated-inputs
`(("python-six" ,python-six)))
(native-inputs
- `(("python-pycodestyle" ,python-pycodestyle)))
+ `(("python-flake8" ,python-flake8)
+ ("python-pycodestyle" ,python-pycodestyle)))
(home-page "https://github.com/gruns/orderedmultidict")
(synopsis "Python Ordered Multivalue Dictionary - omdict")
(description "This package contains a library for ordered multivalue