summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-12 13:34:15 -0500
committerLeo Famulari <leo@famulari.name>2022-01-12 13:34:49 -0500
commitd5ae6739fdb4786c49d33de3fec9872c73d2e311 (patch)
tree3ef563d81c9a0b6808eaa5d2268e2418180edf36 /gnu/packages/python-xyz.scm
parent8e8a2377b6b073c9341f246383fdb03828407711 (diff)
downloadguix-patches-d5ae6739fdb4786c49d33de3fec9872c73d2e311.tar
guix-patches-d5ae6739fdb4786c49d33de3fec9872c73d2e311.tar.gz
gnu: Remove python-msgpack-transitional.
This package is obsolete and unused. * gnu/packages/python-xyz.scm (python-msgpack-transitional): Remove variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4df794eb60..0b0183efdf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10846,37 +10846,6 @@ reading and writing MessagePack data.")
(home-page "https://pypi.org/project/msgpack/")
(license license:asl2.0)))
-;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
-;; release 0.5. Some packages like borg still call it by the old name for now.
-;; <https://bugs.gnu.org/30662>
-(define-public python-msgpack-transitional
- (package
- (inherit python-msgpack)
- (name "python-msgpack-transitional")
- (version "0.5.6")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "msgpack" version))
- (sha256
- (base32
- "1hz2dba1nvvn52afg34liijsm7kn65cmn06dl0xbwld6bb4cis0f"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-msgpack)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'configure-transitional
- (lambda _
- ;; Keep using the old name.
- (substitute* "setup.py"
- (("TRANSITIONAL = False")
- "TRANSITIONAL = 1"))
- ;; This old version is not compatible with Python 3.9
- (substitute* '("test/test_buffer.py" "test/test_extension.py")
- ((".tostring\\(") ".tobytes("))
- (substitute* '("test/test_buffer.py" "test/test_extension.py")
- ((".fromstring\\(") ".frombytes("))
- #t))))))))
-
(define-public python2-msgpack
(package-with-python2 python-msgpack))