summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 11:38:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 11:43:20 +0100
commitc20813bb08d19d424a5965da467599284adad8fc (patch)
tree97335243a78a116d8c51181c4246be74ce8c79a1 /gnu/packages/python-xyz.scm
parent0bd166253a61f43763d488ba592c570bc6a558cd (diff)
downloadguix-patches-c20813bb08d19d424a5965da467599284adad8fc.tar
guix-patches-c20813bb08d19d424a5965da467599284adad8fc.tar.gz
gnu: Add python-lmfit.
* gnu/packages/python-xyz.scm (python-lmfit): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ae80bda6d..a9fa391bb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11607,6 +11607,36 @@ expression.")
using the @code{ast} module")
(license license:expat)))
+(define-public python-lmfit
+ (package
+ (name "python-lmfit")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lmfit" version))
+ (sha256
+ (base32
+ "0iab33jjb60f8kn0k0cqb0vjp1mdskks2n3kpn97zkw5cvjhq2b7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-asteval" ,python-asteval)
+ ("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-uncertainties" ,python-uncertainties)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://lmfit.github.io/lmfit-py/")
+ (synopsis "Least-Squares minimization with bounds and constraints")
+ (description
+ "Lmfit provides a high-level interface to non-linear optimization and
+curve fitting problems for Python. It builds on and extends many of the
+optimization methods of @code{scipy.optimize}. Initially inspired by (and
+named for) extending the Levenberg-Marquardt method from
+@code{scipy.optimize.leastsq}, lmfit now provides a number of useful
+enhancements to optimization and data fitting problems.")
+ (license license:bsd-3)))
+
(define-public python-boto
(package
(name "python-boto")