summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 12:08:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:28 -0400
commit21f29263f3572c4a273d9e548adb8c8c8882e445 (patch)
tree5d03ae7360fe10dc72b222d475af488db1745455 /gnu/packages/python-xyz.scm
parent3d72680d0ea3f9cd42364006e8c1886a9fc3a718 (diff)
downloadguix-patches-21f29263f3572c4a273d9e548adb8c8c8882e445.tar
guix-patches-21f29263f3572c4a273d9e548adb8c8c8882e445.tar.gz
gnu: Add python-autocommand.
* gnu/packages/python-xyz.scm (python-autocommand): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 58902afd39..f7cae9e656 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7097,6 +7097,36 @@ multiple values for the same key. An ordered multivalue dictionary is a
multivalue dictionary that retains the order of insertions and deletions.")
(license license:unlicense)))
+(define-public python-autocommand
+ (package
+ (name "python-autocommand")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "autocommand" version))
+ (sha256
+ (base32 "03qp9xx4dq81ljhf56r21gp5j0lpqs1vaw99g0d84i97s3lj1m7y"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; This test fails with an invalid syntax error on 'task1 =
+ ;; asyncio.async(coro_1())' (see:
+ ;; https://github.com/Lucretiel/autocommand/issues/20).
+ (delete-file "test/test_autoasync.py")
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest python-pytest-asyncio))
+ (home-page "https://github.com/Lucretiel/autocommand")
+ (synopsis "Python library to build a command-line from a function")
+ (description "@code{autocommand} is library to automatically generate and
+run simple @code{argparse} parsers from function signatures.")
+ (license license:lgpl3+)))
+
(define-public python-autopep8
(package
(name "python-autopep8")