summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-13 12:40:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-15 22:43:58 +0000
commiteb0f35e16db46642550cddca9f13c7c39f6c2da5 (patch)
treee75af12725acc23754114a34f3a3900650a0cf69 /gnu/packages/python-web.scm
parent68763a00a30decdf04c05fcfe62e6d538b1a0bcf (diff)
downloadguix-patches-eb0f35e16db46642550cddca9f13c7c39f6c2da5.tar
guix-patches-eb0f35e16db46642550cddca9f13c7c39f6c2da5.tar.gz
gnu: hypercorn: Reformat with guix style.
* gnu/packages/python-web.scm (hypercorn): Reformat with guix style.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 27fa183465..0c7303fa99 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2380,32 +2380,30 @@ RFC6455, regardless of your programming paradigm.")
(package
(name "hypercorn")
(version "0.14.4")
- (source (origin
- (method git-fetch) ;PyPI does not have tests
- (uri (git-reference
- (url "https://github.com/pgjones/hypercorn")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0zyf5b8959sd12ycmqzvsb8746i3gn76rz55gxvix5cwj672m7yx"))))
+ (source
+ (origin
+ (method git-fetch) ;PyPI does not have tests
+ (uri (git-reference
+ (url "https://github.com/pgjones/hypercorn")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zyf5b8959sd12ycmqzvsb8746i3gn76rz55gxvix5cwj672m7yx"))))
(build-system pyproject-build-system)
;; Propagate because Hypercorn also exposes functionality over a module.
- (propagated-inputs
- (list python-exceptiongroup
- python-h11
- python-h2
- python-priority
- python-tomli
- python-wsproto))
- (native-inputs
- (list python-hypothesis
- python-poetry-core
- python-pytest
- python-pytest-asyncio
- python-pytest-cov
- python-pytest-trio
- python-trio))
+ (propagated-inputs (list python-exceptiongroup
+ python-h11
+ python-h2
+ python-priority
+ python-tomli
+ python-wsproto))
+ (native-inputs (list python-hypothesis
+ python-poetry-core
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-pytest-trio
+ python-trio))
(home-page "https://gitlab.com/pgjones/hypercorn/")
(synopsis "ASGI Server based on Hyper libraries")
(description