summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2024-06-17 16:49:13 +1000
committerjgart <jgart@dismail.de>2024-06-17 17:15:02 -0500
commit2e819f7f0eba26e56e705a9207d0d912d9add868 (patch)
tree706e2ab86f03c8ad2a21a97b28c5edb99f7cfc66 /gnu/packages/python-web.scm
parent6515cff981f564fc68816ffca260cd70f6250f70 (diff)
downloadguix-patches-2e819f7f0eba26e56e705a9207d0d912d9add868.tar
guix-patches-2e819f7f0eba26e56e705a9207d0d912d9add868.tar.gz
gnu: python-wtforms: Update to 3.1.2.
* gnu/packages/python-web.scm (python-wtforms): Update to 3.1.2. Change-Id: Id8119d0536d4d2dfa5c81de37013af68489c5fa5 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm33
1 files changed, 8 insertions, 25 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5ca50fa5a6..fae4b8bf0f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5268,35 +5268,18 @@ addon modules.")
(define-public python-wtforms
(package
(name "python-wtforms")
- (version "2.3.3")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "WTForms" version))
+ (uri (pypi-uri "wtforms" version))
(sha256
- (base32
- "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-bundled-test
- (lambda _
- ;; Delete test copied from a third party package that fails
- ;; with newer SQLAlchemy. This can be removed for 3.0.
- ;; See <https://github.com/wtforms/wtforms/issues/696>.
- (delete-file "tests/ext_sqlalchemy.py")))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "setup.py" "compile_catalog")
- (invoke "python" "tests/runtests.py")))))))
- (native-inputs
- (list python-dateutil python-sqlalchemy))
- (propagated-inputs
- (list python-babel python-email-validator python-markupsafe))
- (home-page "http://wtforms.simplecodes.com/")
+ (base32 "1fblnkzvs6339glwx8bskdjy7nhn2ap90y9g6b399713sy063mzq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-hatchling python-pytest))
+ (propagated-inputs (list python-babel python-email-validator
+ python-markupsafe))
+ (home-page "https://wtforms.readthedocs.io/")
(synopsis
"Form validation and rendering library for Python web development")
(description