summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-03-03 21:55:36 -0600
committerEric Bavier <bavier@member.fsf.org>2021-03-14 13:24:21 -0500
commit7164d2105af9d0ebd53f5f4ecbaf1ecd02825e79 (patch)
tree1b1e0c468853a74619f7268e4e666b60542a285d /gnu/packages/python-web.scm
parentaf25357b7d8b37fd0da040ff847bd243c3660132 (diff)
downloadguix-patches-7164d2105af9d0ebd53f5f4ecbaf1ecd02825e79.tar
guix-patches-7164d2105af9d0ebd53f5f4ecbaf1ecd02825e79.tar.gz
gnu: Add python-engineio
* gnu/packages/python-web.scm (python-engineio): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8cfddcdfac..586e778bff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2017, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
@@ -3806,6 +3806,29 @@ this it tries to be opinion-free and very extendable.")
(define-public python2-elasticsearch
(package-with-python2 python-elasticsearch))
+(define-public python-engineio
+ (package
+ (name "python-engineio")
+ (version "4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-engineio" version))
+ (sha256
+ (base32
+ "0xqkjjxbxakz9fd7v94rkr2r5r9nrkap2c3gf3abbd0j6ld5qmxv"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)
+ ("python-requests" ,python-requests)
+ ("python-websocket-client" ,python-websocket-client)))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball.
+ (home-page "https://github.com/miguelgrinberg/python-engineio/")
+ (synopsis "Engine.IO server")
+ (description "Python implementation of the Engine.IO realtime client and
+server.")
+ (license license:expat)))
+
(define-public python-flask-script
(package
(name "python-flask-script")