summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2020-12-17 10:59:43 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-17 22:26:31 +0200
commit22e06297b1982f75aaadddba616b1052e506e4a0 (patch)
treed6230ff563120e374ea696051030fcd3051cb0c6 /gnu/packages/python-web.scm
parent687ef47768d12d36dd3718be564433fbb5309b0d (diff)
downloadguix-patches-22e06297b1982f75aaadddba616b1052e506e4a0.tar
guix-patches-22e06297b1982f75aaadddba616b1052e506e4a0.tar.gz
gnu: python-httpcore: Upgrade to 0.12.2.
httpx was upgraded in commit bc49b009bf08326b55aea3508a6b677a065d5a31, but was broken, because it requests this new version of httpcore. * gnu/packages/python-web.scm (python-httpcore)[version]: Upgrade to 0.12.2. [arguments]: Respect tests? argument. Disable tests. Remove obsolete phases. [native-inputs]: Remove obsolete comment regarding mitmproxy. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm34
1 files changed, 11 insertions, 23 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f88178ab2c..b0c0c0ae36 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4915,7 +4915,7 @@ and serve updated contents upon changes to the directory.")
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.11.0")
+ (version "0.12.2")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -4925,33 +4925,21 @@ and serve updated contents upon changes to the directory.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "01bhajcxqgkdzg7b7x0fqs2lwcfsajlgqwi1nlxx58jss7g2kxn9"))))
+ (base32 "1nrwwfdqjfc2a1k3j41cdwkprwvplf95fwmypdl2aq2qgp3209q0"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f ; Tests hang at 98%
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-unavailable-tests
- (lambda _
- ;; These tests require 'mitmproxy' which is not packaged.
- (for-each (lambda (f)
- (delete-file f))
- '("tests/conftest.py"
- "tests/sync_tests/test_interfaces.py"
- "tests/async_tests/test_interfaces.py"))
- #t))
- (add-after 'remove-unavailable-tests 'force-h11-version
- ;; Allow build with h11 >= 0.10.
- (lambda _
- (substitute* "setup.py" (("h11>=0.8,<0.10") "h11"))
- #t))
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "--cov=httpcore"
- "--cov=tests" "tests"))))))
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "--cov=httpcore"
+ "--cov=tests" "tests"))
+ #t)))))
(native-inputs
- `(;; ("mitmproxy" ,mitmproxy) ;; TODO: Package this.
- ("python-autoflake" ,python-autoflake)
+ `(("python-autoflake" ,python-autoflake)
("python-flake8" ,python-flake8)
("python-flake8-bugbear" ,python-flake8-bugbear)
("python-flake8-pie" ,python-flake8-pie)