summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:24:22 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:20:09 +0200
commitc46c8531dd35db5af0e37a9230acafa9215080ef (patch)
tree926758eeb55ff1d50def75050165905528b9633f /gnu/packages/python-web.scm
parenta6e70f3f0c5bdeaeba87ee847e94e60be4cfc08d (diff)
downloadguix-patches-c46c8531dd35db5af0e37a9230acafa9215080ef.tar
guix-patches-c46c8531dd35db5af0e37a9230acafa9215080ef.tar.gz
gnu: python-h11: Respect "--without-tests".
* gnu/packages/python-web.scm (python-h11)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index acabe00846..d175fbb061 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -908,8 +908,9 @@ for use in Python programs that implement HTTP/2.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/python-hyper/h11")