summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 00:10:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:51 -0400
commitef370c850115bcb5f158d4ac1bc386c3df9f7af1 (patch)
treed05b6f29bce71f77c01dbe0c33e8895a4bce18aa /gnu/packages/python-web.scm
parentb9fc4781925fd783c89d8c75ee47cafa2171a78a (diff)
downloadguix-patches-ef370c850115bcb5f158d4ac1bc386c3df9f7af1.tar
guix-patches-ef370c850115bcb5f158d4ac1bc386c3df9f7af1.tar.gz
gnu: Add python-httpx-bootstrap.
* gnu/packages/python-web.scm (python-httpx-bootstrap): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 28c2ae9b13..1aa5342e8d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5412,6 +5412,17 @@ Plus all the standard features of requests:
@end itemize")
(license license:bsd-3)))
+;;; Variant used to break a cycle with python-uvicorn.
+(define-public python-httpx-bootstrap
+ (hidden-package
+ (package/inherit python-httpx
+ (name "python-httpx-bootstrap")
+ (arguments (list #:tests? #f))
+ (native-inputs '())
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-httpx)
+ (replace "python-httpcore" python-httpcore-bootstrap))))))
+
(define-public python-wsgiprox
(package
(name "python-wsgiprox")